Symptom
A Microsoft 365 backup fails with the following error:
Unable to complete the backup due to temporary throttling limitations of the third-party provider. |
This can happen for Exchange, OneDrive, SharePoint or Teams.
Cause
The third-party provider referred to in the error message is Microsoft.
To enable us to backup and restore M365 data, we make use of the Microsoft Graph API. Microsoft limits the number of concurrent calls our system can make to this API within a certain time period, as well as the number of files that can be accessed. These limits ensure the stable performance of Microsoft's services, but they also have implications for backups.
If our service exceeds the allowed limit of calls within a given time period, any further calls made within the same period are throttled (cut off) by Microsoft. Throttling often occurs during popular backup times, when M365 backups for many customers are running in our system simultaneously. Backups that were in progress when throttling occurred will only resume once the specific time period elapses.
Throttling is controlled by Microsoft and as such cannot be resolved by our support team.
Solution
This error does not indicate a problem with your backups. Below are steps you can take to prevent the error.
1. Wait for the next scheduled backup, which is likely to be successful.
2. Wait at least 30 minutes after seeing the error, then manually initiate a new backup.
3. Permanently reschedule the backups for the affected backup set/s to a different time.
4. Consider what other apps in your environment could be running against the Microsoft API, as Microsoft's limits are shared across all apps for your tenant.
Was this article helpful?
That’s Great!
Thank you for your feedback
Sorry! We couldn't be helpful
Thank you for your feedback
Feedback sent
We appreciate your effort and will try to fix the article