1646 - M365 backup fails due to throttling limitations

Modified on Tue, 10 Mar at 8:04 AM

Symptom

A Microsoft 365 backup fails with the following error:

Unable to complete the backup due to temporary throttling limitations of the third-party provider. 
Please reattempt the backup later or wait for the next scheduled backup to complete.

This can happen for Exchange, OneDrive, SharePoint or Teams.

 

Cause

This happens because the backup task was throttled (i.e. cut off) by a third-party provider, in this case Microsoft.

To enable us to backup and restore Microsoft 365 data, we make use of the Microsoft Graph API. The Graph API limits our service to a certain number of concurrent tasks at a given time. If our system exceeds this number (for example, during popular backup times, when Microsoft 365 backups for dozens of customers are running simultaneously), Microsoft throttles our system’s interaction with the Graph API and time needs to pass before the backup can be reattempted. We have no control over this throttling.

Note: API limits are shared across all apps for your tenant that are using the Microsoft APIs. If you see this error, consider what else could be running against the APIs.

 

Solution

This error does not indicate a problem with the backup. There are three options for addressing the error:

1. Ignore the error and wait for the next scheduled backup, which is likely to be successful.

2. Wait at least 30 minutes after seeing the error, then manually initiate a new backup.

3. Reschedule the backups for the affected backup set/s to a different time.

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