Symptom
A Microsoft 365 backup in the RedApp completes with the warning "Malware detected by Microsoft 365".
Cause
Redstor's systems make use of the Microsoft Graph API when backing up M365 data. As a security measure, if Microsoft determines that a file possibly contains malware, the API will block Redstor's access to the file. This means that the file cannot be backed up by our systems, which leads to the warning being shown.
You can read more about Microsoft's built-in malware protection in this article on their knowledge base.
Solution
If you know the relevant file to be safe (i.e. the malware flag on Microsoft's side is a false positive), you will need to submit the file to Microsoft to get it whitelisted.
Alternatively, you can remove the file and reattempt the backup.
Was this article helpful?
That’s Great!
Thank you for your feedback
Sorry! We couldn't be helpful
Thank you for your feedback
Feedback sent
We appreciate your effort and will try to fix the article