1577 - RedApp: Xero organisation cannot be added to more than one company

Modified on Tue, 5 Aug at 1:21 PM

Symptom

Once a backup set for a Xero organisation has been created in the RedApp, it is not possible to add the same Xero organisation to another backup set while the original exists. The same Xero organisation can therefore not be added to two different companies in the RedApp, nor can two different backup sets of the same Xero organisation exist within one company.

 

Cause 

This happens because Xero restricts access to an organisation's data to only one backup set at a time (1 organisation = 1 backup set). If a Xero organisation has already been added to the RedApp, it will appear greyed out on the list of available organisations whenever a new backup set is added.

If you are having trouble adding a Xero backup set, this may be because it has already been added to another company by a different admin.

 

Solution

If you need to add an existing Xero organisation to a different backup set, you will first need to disconnect the organisation from the Redstor Cloud Backup app.

To do this, follow the revocation steps in Article 1426, then re-add the backup set to the correct company in the RedApp.

 

Was this article helpful?

That’s Great!

Thank you for your feedback

Sorry! We couldn't be helpful

Thank you for your feedback

Let us know how can we improve this article!

Select at least one of the reasons
CAPTCHA verification is required.

Feedback sent

We appreciate your effort and will try to fix the article