1456 - VSS error in the Windows event log: ConvertStringSidToSid

Modified on Mon, 21 Jul at 12:57 PM

Symptom

An error presents that starts with "A VSS error occurred in the Windows event log" and contains the function "ConvertStringSidToSid". An example is shown below.

Error: A VSS error occurred in the Windows event log. See FAQ https://bit.ly/2KQA9WI: 'source: 
VSS, level: Error, message: ConvertStringSidToSid(S-1-5-80-3919359670-3540430778-4246408611-
3681914861-206046543.bak)0x80070539, The security ID structure is invalid. Operation: OnIdentify
event Gathering Writer Data Context: Execution Context: Shadow Copy Optimization Writer Writer
Class Id: {4dc3bdd4-ab48-4d07-adb0-3bee2926fd7f} Writer Name: Shadow Copy Optimization Writer
Writer Instance ID: {b85e7187-0689-495e-9347-6d76f2eae01c}'

You may also see "The security ID structure is invalid."

 

Cause

The function ConvertStringSidToSid in the error indicates an issue in the Windows Registry. This usually refers to when Redstor's service tries to backup the registry via VSS but certain aspects cannot be fixed, as they are unreadable. One of these aspects is user accounts that have been removed and are stuck in SID format, resulting in an invalid entry in the following registry subkey: HKey_Local_Machine\Software\Microsoft\Windows NT\CurrentVersion\ProfileList.

An SID is a placeholder for the security identifier (SID) of the user account that is experiencing the problem.

 

Solution

To resolve this,

  1. Check for unresolveable SIDs in the Administrators group on the SCVMM source machine. If any exist, delete them. (Note that the profiles will vary from machine to machine.)
  2. Open the Registry Editor (regedit) and locate the abovementioned ProfileList subkey.
  3. Check the subkey for an entry named SID.bak.
  4. Backup the registry first, then delete the SID.bak entry as this may be what is causing the failure. The SID.bak subkey should contain a ProfileImagePath registry entry that points to the original profile folder of the user account that is experiencing the problem.
  5. Reboot the machine and retry the backup.

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