1357 - Error: The reply URL specified in the request does not match the reply URLs configured for the application

Modified on Mon, 21 Jul at 12:56 PM

Symptom

When trying to log into the Storage Platform Console or the RedApp, the user encounters the following error: "The reply URL specified in the request does not match the reply URLs configured for the application." This can happen with any identity provider.

Cause

This happens because the redirect_uri parameter in the URL where the user is being sent to authenticate does not correspond to the parameter/s you've allowed on the identity provider side.
 

Solution

To address this, inspect the URL where the user is being sent and look for something along the pattern redirect_uri=https%3A%2F%2Fsp.dev.redstor.com%2Fauth%2Ftoken. This is the encoded version of the parameter that must be allowed at your identity provider to allow you to log in.

Once you know what this should be, go to your identity provider portal and make sure the appropriate redirect URI (non-encoded version, as below) has been allowed. Depending on which Redstor platform you use, this will be one of the following:

Note: You will need to add a second URI for the RedApp if you make use of it.

  • https://sp.pro.redstor.com/auth/token
  • https://us.pro.redstor.com/auth/token
  • https://uk.pro.redstor.com/auth/token?
  • https://zaapi.pro.redstor.com/auth/token
  • https://api.pro.redstor.com/auth/token (RedApp)
  • https://zasp.pro.redstor.com/auth/token (RedApp)

 

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