496 - Unable to perform an Integrity Check while a mirror is in progress

Modified on Mon, 21 Jul at 12:54 PM

 

Symptom

The following error is seen in the StorageServer log when trying to perform a Integrity Check:

Info: CLIENT\ACCOUNT -  Integrity: Quick Integrity Check with Fixes Initiated
Error: CLIENT\ACCOUNT -  Integrity: Unable to perform an Integrity Check while a mirror is in progress 

 

Cause

Unless the account has completed a mirror under certain circumstances, the MS will add the DataindexPending=true flag to the LocalSettings.txt file of this account. While DataIndexPending=true, the Integrity Check process will not be allowed.

 

Solution

  1. Browse to the GUID for this account on the StorageServer, eg: C:\ProgramData\Attix5 Pro\SS_Service\Data\<AccountGUID>.
  2. Edit the file LocalSettings.txt. 
  3. Change DataIndexPending=true to false (or completely remove DataIndexPending=true from the text file).
  4. Save the changes. 
  5. Run a Quick Integrity Check with Fixes.  

 

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