1214 - No option to open InstantData from the Console when connecting to StorageServers through AccountServer

Modified on Mon, 21 Jul at 12:51 PM

Symptom

If the Connect to StorageServers through AccountServer option is enabled on a particular Storage Platform, the InstantData button is not visible on the Console toolbar, and the context menu for an individual account shows only the Share option under InstantData.

 

Cause

Enabling a connection to a StorageServer(s) through the AccountServer means that all traffic will be tunnelled through the AccountServer, since the Console will not be able to connect directly to some (or all) of the StorageServers - for example, due to firewall or routing issues. While these issues may pertain to only a subset of StorageServers, the setting affects the whole Storage Platform for that connection.

Because the amount of data that gets transferred when using InstantData may be very large, InstantData does not support tunnelling via the AccountServer. As such, the InstantData button and InstantData > Open context option will be hidden when a connection through the AccountServer is enabled. If you cannot connect to the relevant StorageServer(s) from the machine that hosts your Console, you will not be able to use InstantData.

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