1323 - Error: "Please rehydrate all stubs before deleting the account"

Modified on Tue, 5 Aug at 1:20 PM

Symptom

On attempting to delete an account that has archived data on the Storage Platform, the following error presents:

This account uses Archiving and has [X] stubbed files.  Please rehydrate all stubs before
deleting the account.

 

Cause

Accounts that contain files that have been stubbed as part of the Archiving process cannot be removed through the Storage Platform Console. Since deleting such an account will make the archived files irretrievable, this is a safety measure to prevent the accidental removal of accounts that contain the only copy of the data.

 

Solution

There are two possible solutions for this error.

1. Rehydrate the archived files

Rehydration can be done in one of two ways:

  • by using the rehydration functionality in ESE (see Article 1495), or
  • by moving the stubbed files over a network share.

Once the stubbed data has been rehydrated, the account deletion can be retried.

2. Manipulate the back-end

If rehydration is not optimal, the rehydration requirement can be bypassed manually from the back-end, after which you will be able to delete the account using the Console. Please log a ticket with the Redstor Support team to assist with this. Note that deleting a backup account also deletes its archived files, meaning that account deletion in this way will result in data loss of the unhydrated stub files.

 

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