1134 - Error: Agent cannot open due to local port conflict

Modified on Mon, 11 Aug at 12:39 PM

Symptom

The initial presentation of this error is either

  • a failure in starting the Redstor service, or
  • a "Service not running" error message on opening the ESE Agent.


Cause

This error is encountered when the port which the Agent has selected for use is being used by another service, and is therefore unavailable when the Agent tries to bind to it. This is known as a JVM_Bind error.


To confirm that the JVM_Bind error is the cause of the problem, check the service.log file (default location

C:\ProgramData\Redstor Pro\Backup Client ESE\logs\). You should see the following message there: 


FATAL – Could not bind to socket using address ***.*.*.* and port *****
Java.net.BindException: Address already in use: JVM_Bind

 

Solution

To resolve the issue, you will need to force the Agent to bind to a new local port number. To do this:


1. Open the Agent's a5backup.properties file (default location C:\Program Files\Redstor Pro\Backup Client ESE).


2. Locate the following line and delete it:


service.rpc-server.localhost.port=*****


3. Save and close the file.


4. Restart the backup service. If the service starts normally, the Agent was able to bind to a new local port and the issue has been resolved. You can now use the Agent as you normally would. 

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