1220 - ESE: Files are skipped during backup with error "Cloud files are not supported"

Modified on Tue, 5 Aug at 1:17 PM

Symptom

Certain files are skipped during a backup, with the logs showing the error "Cloud files are not supported". This can happen whether or not a cloud service such as OneDrive is running on the machine/server. This error can appear even when the appropriate permissions are set and files are syncing correctly. 

 

Cause

Because we cannot backup files for which the data is not present locally, ESE attempts to detect stubbed files on a machine/server by checking for the following factors:

 

  • file size > 0
  • size on disk = 0
  • reparse point = true
  • RecallOnDataAccess attribute = true

If any one of these is true for a file, the file will be seen as a cloud file by ESE and will be skipped during backup.

Even if a cloud service is not running on the machine/server, the files may have been moved from the cloud to their current location, retaining some of their attributes and resulting in the same error. Any cloud service could have these attributes set explicitly or inherited.

 

Solution

There are four possible solutions to this error:

Solution 1: Investigate the file attributes

These files are being skipped because, for whatever reason, they have certain attributes (e.g. A for Archive or O for Offline) that flag them to our system as cloud files, even if they are not stored in the cloud. These attributes can be seen in the Details tab of the file properties.

file_attributes.png

One way to resolve the problem is to check each application on the relevant machine/server to determine if it applies the problematic attributes. You can also investigate why the files are being created with these attributes, to prevent this error happening in future.

 

Solution 2: Change settings in OneDrive

If OneDrive is running on the machine/server, try the following steps:

1. Right-click the relevant OneDrive file/directory in your file explorer and check Always keep on this device.

Screenshot__800_.png

 

2. Check the Files On-Demand setting in OneDrive. This setting must be disabled for backups to work. 

files_on_demand.png

Note: After disabling this option, the OneDrive files will need to be rehydrated, which will take time. If a backup is attempted before rehydration is completeyou may still get errors. 

 

Solution 3: Apply exclusions

Exclude any directories on which you are using third-party archiving or data tiering. Article 1085 may be useful if these directories are being included by VSS.

 

Solution 4: Disable VSS

You can consider disabling VSS (if this is an option for you) before attempting the backup again. However, this measure should only be used as a last resort as it may have a number of knock-on effects.

To disable VSS, go to Options > Advanced in your ESE agent. 

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