1291 - FSR to Azure error: Client does not have authorization to perform action

Modified on Mon, 21 Jul at 12:51 PM

Symptom

When a user attempts Full System Recovery (FSR) of an account to Azure, the following error presents:
 
Error: The client "TenantAccount" with object id 'ID' does not have authorization to perform action 
'Microsoft.Storage/storageAccounts/listKeys/action' over scope
'/subscriptions/ID/resourceGroups/RSG-CORE-DR/providers/Microsoft.Storage/storageAccounts/redstorbackup'
or the scope is invalid. If access was recently granted, please refresh your credentials.


Cause

Only certain roles have rights to initiate FSR to Azure.

 

Solution

Assign one of the following roles to the relevant tenant account in the subscription:
  • Azure Resource Manager Owner
  • Azure Resource Manager Contributor
  • Storage Account Contributor

 

Was this article helpful?

That’s Great!

Thank you for your feedback

Sorry! We couldn't be helpful

Thank you for your feedback

Let us know how can we improve this article!

Select at least one of the reasons
CAPTCHA verification is required.

Feedback sent

We appreciate your effort and will try to fix the article